the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Resolved Food Reclamation Facility Problem

slink_v_0000

Member
Messages
64
I have so far advanced your industrial food plot to Tasty Pasty, Improved Meat Factory, and Cannery levels with no problems. However, the Food Reclamation Facility seems to not work correctly. After a short while, food begins to float around the vicinity, also sometimes exploding out of the collection bin or falling from above head-level, and eventually the game crashes if you are standing in front of it watching. I had this happen at Starlight and it resulted in having to wipe the settlement because attempting to scrap the plot crashed the game. The new Starlight was working smoothly until I rebuilt the Food Reclamation Facility again, and it again began crashing with floating food. I reloaded from a previous save in that case and tried again at Egret Tours. I have posted screenshots of the floating food at Egret Tours on Nexus. Feel free to delete the screenshots after you have viewed them. They are just for debugging purposes.
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
Ugh, that sounds bad.

I won't be able to fix this before next week, so for the time being, better stay away from that, and the cannery, too, I guess.

I don't even know what could cause it. I'm just using @kinggath 's conveyor script. Is there a known way to misconfigure it to cause such behavior?
 

slink_v_0000

Member
Messages
64
The cannery at Kingsport appears to be working okay. At the very beginning one or two pieces of food went awry, but then it settled down and has had no glitches that I have observed. Certainly Kingsport does not crash when I visit, which is what eventually was happening at Starlight. It was not a crash immediately on entry, but rather as if some spool was winding up tight and then snapping a thread after a short while. I was able to rescue my settlers to another settlement, three or four at a time, rushing around and then running away before the game could crash. I wiped it then with the gavel but two items stayed suspended irremoveably (sp?) in mid-air and the empty city thought it was producing a large amount of food. I ended up using the experimental procedure of removing the REFR with ReSaver.
 

slink_v_0000

Member
Messages
64
BTW, I have a save with the misbehaving Reclamation building at Egret, made before I reloaded, so if you have any diagnostic console commands you want me to run I can do that.
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
commands, no idea. but, how big is the save? could you upload it?

though, again, I won't be able to do anything till next week friday
 

slink_v_0000

Member
Messages
64
I'll try to upload it in a z7 compression file. Nope, says it is too large even compressed. 10,680 Kb. I will try to upload it to my website but I am having to recover my ftp password via an ISP support ticket so it will take some time.
 

slink_v_0000

Member
Messages
64
I had to send the link in a conversation because my Like:Post ratio is 0% and adding a couple of likes did not help. I only have 6 posts so 2 likes should have been more than 1%. Oh well.
 

slink_v_0000

Member
Messages
64
I posted a link to my saved game in a conversation with you, Pra. Let me know when you have got the save so I can take it off my website. Thanks.
 

RayBo

Well-Known Member
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,166
Ugh, that sounds bad.

I won't be able to fix this before next week, so for the time being, better stay away from that, and the cannery, too, I guess.

I don't even know what could cause it. I'm just using @kinggath 's conveyor script. Is there a known way to misconfigure it to cause such behavior?

Pra,

When you get back I am posting this link below. Just in case these two issues are related?

https://simsettlements.com/site/index.php?threads/4-08-ctd-issue.10144/#post-70298
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
Downloaded the file. You can delete it now.
Also, could you check if it goes away using that fix raybo linked?
 

slink_v_0000

Member
Messages
64
I downloaded 4.07 (I had skipped from 4.06 to 4.08) but the packages were still moving outside the building with 4.07. I don't think I have any interior Caps General stores. Certainly none in Egret Tours and there were none in Starlight Drive-In earlier. I usually reserve the interior plots for residential, plus a few recreational.
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
Can you try this file? I redid the conveyors for the reclamation facility.
You definitely need to refresh the plot.
 

Attachments

  • SS-PrasRandomAddon.esp
    430.1 KB · Views: 78

slink_v_0000

Member
Messages
64
I upgraded to SS 4.0.9 and changed the esp to your new one. I fast-traveled to Home Plate to allow SS to settle in, sleeping overnight. Then I fast-traveled back to Egret Tours and refreshed the plot. It went down to bare ground and rebuilt itself. The food began moving normally except for one box that appeared stuck in place, but soon some of them were floating in interesting ways, sometimes exploding out of the shed. In a matter of maybe five real-life minutes, the game crashed.
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
I have now the suspicion that something's wrong with your plot (the actual plot, not the blueprint). That, or it's a mod conflict, somehow.

Can you try scrapping the plot, and bulding a new one? The command to force-upgrade advanced industrials is
Code:
setpv bIsUpgradeReady true
(run on the plot, click the power pole while console is open for best results)
 

slink_v_0000

Member
Messages
64
Okay, using the Willy save from sleeping in Home Plate, I went to Egret. I scrapped the plot. I saved it with the plot scrapped, so we can go from there. I used your newer version of your mod. I built a new Food Warehouse and advanced it through two more steps, each time it had completed the previous build.
1. The first food out of the processor stays stationary. In this case it was an Instamash. I believe I have seen a Dandy Boys Apple do the same thing, but maybe not.
2. The subsequent foods come out normally.
3. Eventually the stationary Instamash flew to the right and vanished. I was not properly positioned to see if it went through the wall, but it was not visible inside or out when I walked around.
4. I caught sight of something brown (Dandy Boy, maybe) darting around to the right of the building, at many angles, and floating down to the ground. Before I could see if it was laying there, the game crashed.
I can try it next with my new character, which is a smaller, cleaner file (only 1 Active script).

Edit:
Okay, I tried it with Violet, who only has around ten settlements of no more than 11 settlers. Many have only three or four.
1. There was no stationary food when the belt first started producing food.
2. Everything seemed fine, and then there was a gap in the food being produced.
3. A Fancy Lads Snack Cake appeared in the gap.
4. I looked around and discovered that Fancy Lad Snack Cakes were arriving at the belt from an upper right angle, instead of from inside the machine.
5. Eventually a flock of Fancy Lad Snack Cakes were moving around apparently randomly behind the shed. One bounced to the ground. I approached it to see if I could touch it, and the game crashed.

I could not see any conflict in FO4Edit, but that will not see a problem with scripts, will it?

I have saved this smaller game save under a special name, if you want it.
 
Last edited:

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
what the hell.

I don't know. I honestly don't.

Can you try making a cannery? it has conveyors as well. Or if you have one, does it work?

I couldn't really reproduce it even with your save. Or rather: it kept happening with the plot which was in there already, but not with a fresh one.

Damn, I'm really out of ideas here, sorry :(
 

slink_v_0000

Member
Messages
64
That's interesting, that it happens with the old one but not with a new one. And yes, I have a cannery in Kingsport Lighthouse. It appears to be working normally. I thought it might be because of the upward slope at the end of the conveyor belt in food reclamation factory, when the cannery has a downward slope.

Let me try it with a more-or-less clean character. I have a save just before exiting the vault that only has appearance mods activated. I can try activating just SS and your mod. I will have to give myself the holotape and some materials, using the console.
Edit:
Run 1, starting from the Vault exit aboveground:
SimSettlements.esm
SettlementMenuManager.esp
SS-PrasRandomAddon.esp
Slink_FreeStuff.esp
Slink_IntVaultSuit.esp
AzarPonytailHairstyles.esp
The Eyes Of Beauty.esp

Under F4SE
Place.dll & company
PowerGridTools.dll

Floating Food and crash
==========================
Run #2:

Starting from in Sanctuary with all the hostiles dead, but nothing built. Everything disabled but these three mods. City Manager tape not run yet when I did that.

SimSettlements.esm
SettlementMenuManager.esp
SS-PrasRandomAddon.esp

Under Bethesda Launcher

Took longer, but it finally crashed. Food was floating and flying everywhere, before that.
=======================
I can't get much skimpier than that without wiping my installation and redownloading.

I am running Sim Settlements under Ultra graphics. Would that matter?
 
Last edited:
Top