the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Resolved Food Reclamation Facility Problem

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
I'll try removing the slope so you can test. That does sound like it could at least somewhat make sense, in that it causes it
 

slink_v_0000

Member
Messages
64
I'll try that when you do it. I tried, early this morning, running it with just Sim Settlements and neither of the expansions. I could build it but no conveyor belt appeared. I added Industrial Revolution and I got a conveyor belt, but no food on the belt. It was producing food in the status line, though. Same thing when I added RoTC to both of them. I went back to three-in-one and built it, and got the same bad behavior but there was food displayed. The mod was meant to be used with three-in-one, was it not?

One other thing. If you check Willy's inventory, he has a copy of the exterior of the factory in his MISC. I left it there because I did not know what would happen if I dropped it. I tried dropping it with my crash test dummy just a short while ago, and I got an copy of the exterior wall that cannot be scrapped nor picked up again. I could store it, it says, but I did not try that. I am pretty sure we are not supposed to have copies of buildings in our inventory. :smile
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
Omg, what did I do? :(

It definitely should require IR. The NIFs for the belts seem to be in there. But it should not strictly require 3in1.
That I didn't lock the factory behind IR is definitely my fault. Though I'm not even sure how I would do that, with both 3in1 and the loose IR existing...

I don't even know how I could have messed that up so much. Omg.
The food items are custom MovableStatics which use vanilla meshed and textures. The conveyor belt controllers are custom copies of that SimSettlements activator. Now the script might be from IR, but then it should exist in both the IR and 3in1 BA2s...

I'm at work atm, I can't do any testing. But if you are willing to help even more, could you test if the Cannery's conveyor belts work with just regular SS and IR? Or if normal IR conveyor belts work in that setup? I think the L1 scrap processing thing uses one...
 

slink_v_0000

Member
Messages
64
Okay, the results are in and you can relax. The Tech Salvage and the Cannery both worked fine, the Food Reclamation did not. However, I finally moved the four mods in question directly into Fallout's Data directory and ran the game without the Mod Organizer. The Reclamation worked fine that way. I need to check my Mods directories and see what is overriding vanilla that I did not expect to do so. I will report back when I have results.

That was:
SS
SMM
IR
Pra with newer esp (I can test with the original if you want me to)

no F4SE and no MO2

Success.
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
What. So you are telling me, it was a problem with your setup all along?

Mh, if moving it to the directory fixes it, moving it around in MO2 should work too. Not in the load order, in the main mod list. Though I'm not sure if stuff in Data counts as highest or as lowest priority...

But, on the upside, I did find some actual bugs while looking into this: not only isn't my adv.ind. plot properly hidden behind IndustrialRevolution, neither are IndustrialRevolution blueprints themselves.
(The blueprints themselves are in SimSettlements.esm, the addons only include their assets).

Oh well. I'll just make an update to fix the IR requirement on my end.
 

slink_v_0000

Member
Messages
64
I am back in action with F4SE under MO2, and your May 21 esp. No crashes and no food flying everywhere. I can't say for certain what was interfering because I did not have the patience to test all the mods I took off the list. They were mods I was no longer using and they were not enabled. However, loose meshes and textures appear to override even when the parent esp is not enabled. Several of those mods added new foods to the Commonwealth and one may have altered something that affected the physics of the vanilla foods. I am about to try it with my full enabled mod load. *crosses fingers*

And yes, it was a problem with my setup all along. Abject apologies. Unchecking all my enabled mods should have disabled everything, but apparently not.
 

pra

Well-Known Member
Staff member
Verified Builder
Messages
498
Well, unchecking stuff in MO2 should disable everything installed via MO2, but if you have stuff in the Data folder directly, it can't do anything.

Anyway. I'm uploading a new version now. It is the same ESP as the one I posted here, plus the Food Warehouse should be properly extensionpack-locked.
 

slink_v_0000

Member
Messages
64
Thank you again, pra. And yes, MO2 should disable everything installed by MO2, but it does not. I have nude skins that were installed in MO2, specifically so I could clean up the Steam Fallout 4 Data directory. But regardless of having unchecked Nudes in MO2, my character had no underwear on when I took off her outer clothing. When I ran from the game itself, she had underwear on under her outer clothing. That is because I had cleaned up the games Data directory. The nude skins and meshes are loose files. The take-home lesson here is that loose files override even when the esp is disabled.

I found another example of overriding vanilla by a mod that has not been in use for over a year. Crimsomrider's Unique Furniture had a cat bowl that looked as if it was filled with food. I noticed that I still had that but thought it must be coming from some other mod. Now that Crimsomrider's Unique Furniture is no longer in the list, that bowl appears once again as in vanilla. That mod has a lot of things in it.
 
Last edited:
Top