Bug Custom Faction Soldiers Showing as Hostile

Discussion in 'Conqueror Mod (System Bugs)' started by Takarazuka, Mar 15, 2019.

  1. Takarazuka

    Takarazuka New Member

    Joined:
    Feb 16, 2018
    Messages:
    24
    Likes Received:
    10

    Working on a BOS faction with the new toolkit. I've created a basic recruit for initial testing and they are fine until I order an assault to setup an outpost or vassal. When I approach the soldiers near the location, they are showing as red/hostile, but they do not attack me. As soon as I trigger the actual assault, they return to normal friendlies. I checked through the tutorial about five times to be sure I didn't miss anything and I haven't.

    Interesting note, I didn't have enemy/friendly formlists setup at first and this wasn't a problem. Once I did, this began. Attached the formlists I have created to see if something is not right with them. Thanks!!
     

    Attached Files:

  2. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,271
    Likes Received:
    2,581

    This is nothing wrong with what you're doing, it happens even with Jammer's Gang. I'm uncertain exactly what controls the Red/Green display but they will not attack you - so I consider this a minor issue.
     
  3. Takarazuka

    Takarazuka New Member

    Joined:
    Feb 16, 2018
    Messages:
    24
    Likes Received:
    10

    Ok sounds good... I guess I never even noticed with Jammer's Gang.
     
  4. Rudy

    Rudy Well-Known Member Community Rockstar

    Joined:
    Aug 28, 2018
    Messages:
    205
    Likes Received:
    323

    There are new reports of Faction Packs being hostile towards the PC
    Original Thread: Faction recruits (minutemen) turning hostile
    It seems that the Faction Packs don't want to play well with others.
    Could this be part of the same issue as the bodies not disappearing from a Faction Pack, or is this totally unrelated?
    Thanks!
     
  5. dreaddragoon

    dreaddragoon New Member

    Joined:
    Jun 4, 2019
    Messages:
    7
    Likes Received:
    0

    um found a bug with the settlement pets like molerats when youre raiding a settlement apparently they are considered a "civilian" and wont stay down if i could id send a clip but tbh idk how
     

Share This Page