the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

WS+ now absent from MCM following update to 1.0.4

VanCardboardbox

New Member
Messages
0
After updating the Unofficial Fallout 4 Patch to 2.0.6, Workshop Framework to 1.0.8a and Workshop Plus to 1.0.4. I find that that WS+ no longer appears in the MCM. The hotkeys I set up in the previous version are still working and I can still use WS+ features, but I can not make any further changes to WS+ in the absence of a MCM menu. I wait a fair bit of in-game time mostly outside of settlements thinking that maybe the menu would take some time to kick in, as they sometimes do, but no luck.

Has anyone else found the same? Is there a means of nudging the MCM to notice that WS+ is still there in an updated version?

EDIT to add: Hotkey Manager menu in MCM does show WS+ hotkey selections for Undo/Redo, Save-in-WS-mode and Clone, and permits me to change them. So this, at least, I still have control over.

Since originally posting this I have reinstalled everything again with the same results, then re-installed everything on a clean save, again with the same results.

I have not tried going back to previous versions as I (foolishly) did not preserve a copy of the previous Unofficial Patch and older versions are not kept on the Nexus.
 
Last edited:

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,970
Have you tried manually copying the MCM files from the WSPlus archive to your MCM folder in Fallout 4/Data?
 

VanCardboardbox

New Member
Messages
0
This corrected the problem. It appears that my attempted installs of WS+ 1.0.4 were successfully copying keybinds.json but not config.json. Manually copying this over restored the menu.

I was not familiar with how MCM was set up in ~/Data so not only is WS+ fixed but I am now better equipped to diagnose MCM problems moving forward.

Many thanks!
 
Top