Solved Workshop Framework Slow Performance

Discussion in 'Workshop Framework (Mod Questions Here)' started by Lone_Wolf, Jan 9, 2020.

  1. Lone_Wolf

    Lone_Wolf New Member

    Joined:
    Dec 11, 2018
    Messages:
    12
    Likes Received:
    22

    Okay, just to clarify I am not having any stability issues, and no "sim settlements".

    It is that certain actions seem very slow in workshop mode. Specifically, manually assigning settlers to any activity farming, shops, etc....

    Example assigning a settler to crop production I have to sit in work shop mode and wait while the food count SLOWLY increases, once it hits 6, I get the resource assigned message.

    Another example is assigning to shops where it can take up to 20 sec to get the resource assigned message.

    I don't have to wait for the "resource assigned" message by the way I did test it with just going ahead with assignments. Then just sitting and waiting for the "resource assigned" messages which could take several minutes, as they slowly come in.

    I know over a year ago, the Dev's did a code review, cleanup, and optimization. Is possibly time for that? Has anyone else seen this trend?
     
  2. Phil_T_Casual

    Phil_T_Casual Well-Known Member Community Rockstar

    Joined:
    Dec 18, 2018
    Messages:
    988
    Likes Received:
    1,386

    Sounds like script lag.
    Go idle alone in an internal cell for a couple of hours.
     
  3. Lone_Wolf

    Lone_Wolf New Member

    Joined:
    Dec 11, 2018
    Messages:
    12
    Likes Received:
    22

    "Sounds like script lag." -- Agreed, just wondering if it is just my perception that over the last year, it seems to have possible increased.

    Do you want me to go ahead and close this out?
     
  4. Phil_T_Casual

    Phil_T_Casual Well-Known Member Community Rockstar

    Joined:
    Dec 18, 2018
    Messages:
    988
    Likes Received:
    1,386

    KG is always working to improve optimisation and several systems have been improved over the last year.
    But the engine is the engine and script lag will always be an issue especially when you add other mods that are not SS into the mix.
     
  5. Lone_Wolf

    Lone_Wolf New Member

    Joined:
    Dec 11, 2018
    Messages:
    12
    Likes Received:
    22

    Thanks for the reply. I am going to close this out as it was just a general question.
     
  6. Lone_Wolf

    Lone_Wolf New Member

    Joined:
    Dec 11, 2018
    Messages:
    12
    Likes Received:
    22

    Okay, I am dumb, I cannot figure out how to set this as solved? Should I just delete the thread?
     
  7. Phil_T_Casual

    Phil_T_Casual Well-Known Member Community Rockstar

    Joined:
    Dec 18, 2018
    Messages:
    988
    Likes Received:
    1,386

    Go to edit and click on the prefix.
    Or don't worry about it, 'tis fine.
     

Share This Page