Solved Switching problem

Discussion in 'H.I.-AIO Discussion' started by MPilo, Jul 1, 2017.

Thread Status:
Not open for further replies.
  1. MPilo

    MPilo Member

    Joined:
    May 26, 2017
    Messages:
    66
    Likes Received:
    8

    I just uninstalled your old package House Improvements (or whatever is the right name, the game is saying "kevabl.esp") and also Better Gardens (package name "hi_bettergardens.esp") to switch to the single, huge package with everything in the same place (and also the dungeons :yahoo).

    I'm loading the old save and the game seems to not recognize the switch and it is asking the old packages, what should I do?

    Since you are an expert, I have the same problem with Slum Lord of Jose but not with Bad Neighbours (I uninstalled both to swith to the all-in-one package).

    Thanks for your great work, both modding and on the forum!
     
  2. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    618
    Likes Received:
    632

    Hi! I can answer for the Bad Neighbors / Slum Lord:
    Like you noticed, there's no problem with Bad Neighbors (the old esp and the new all-in-one has the same name).
    For the Slum Lord, the safest way to uninstall is to:
    1. Change all your Slum lord plots to something else
    2. Uninstall the Slum lord mod (and the old Bad Neighbors)
    3. Install the new all-in-one
    4. Enter the game, see that it looks ok and save. (Then you won't get any more complaints about missing esps)
    5. Rebuild the Slum lord plots you want with the ASAM (or T-square)

    Normally, we all make the stuff in our plots scrapable, so if you remove a mod you can still get rid of any stuff left behind. I see that MrJoseCuervo has some things that aren't scrapable and I haven't had the time to fix it all yet, so that's why the extra precaution.

    I'll update the all-in-one webpage with this.

    EDIT: for anyone else reading this, turns out all those steps aren't necessary. You can just uninstall the old ones and install the new.
     
    Last edited: Jul 1, 2017
  3. MPilo

    MPilo Member

    Joined:
    May 26, 2017
    Messages:
    66
    Likes Received:
    8

    Thanks @Tinuvia , I have just a problem... I already uninstalled Slum Lord, is there a way to get back that esp file or I fucked up my save and have to restart the whole game?
     
  4. kevbal

    kevbal Active Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 9, 2017
    Messages:
    467
    Likes Received:
    178

    Its ok if you already removed the old content. Just walk up to the plot and using the ASAM censor on the plot pole select the choose model option and have a blast. Should work with no issues. If you get anything funky after setting the plots to the ones you want now refreshing the plots usually fixes it. :)
     
  5. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    618
    Likes Received:
    632

    No, you are on PC, so you can use the console to disable anything that could be left behind. I'm not sure if there will be a problem, we haven't had any bug report and lots of people have downloaded the all-in-one. This is just precautions :) Let me know how it goes.
     
  6. MPilo

    MPilo Member

    Joined:
    May 26, 2017
    Messages:
    66
    Likes Received:
    8

    Ok guys, I'll try and report back, thanks to both!
     
  7. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    618
    Likes Received:
    632

    Waiting with anticipation ;) ;)
     
  8. MPilo

    MPilo Member

    Joined:
    May 26, 2017
    Messages:
    66
    Likes Received:
    8

    Ok, it works. It is really slow because the engine deletes the unavailable buildings and puts some basics instead, but I can survive it!
    The hard part is that I cannot fast travel, game crashes... It will be a long walk to Jamaica Plain :suicide2

    EDIT: everything of the old buildings vanishes, even without refreshing it with the IBB.
     
  9. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    618
    Likes Received:
    632

    Great! Also any Slum Lord buildings?
     
  10. MPilo

    MPilo Member

    Joined:
    May 26, 2017
    Messages:
    66
    Likes Received:
    8

    Ok I have a lot of problems now. Refresh All Plots is stucked and not refreshing nothing at Abernathy, but the refresh with the IBB works like usual (so nothing is really refreshing).
    I cannot fast travel to other places to reboot the Refresh All, the game crashes.
    I have to travel further to see if it works also with Slum Lord, I don't have them in Sanctuary or Abernathy.
    I don't want to restart the game now that I finally have a decent character that doesn't die from its shadow.

    I think I'm going to have a long night in God Mode running in every settlement, refresh it with IBB, fast travel somewhere at the end hoping that this will solve my problems.
    I'll let you know at the end, now I don't really now where the problem is.
     
  11. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    618
    Likes Received:
    632

    Hope it works out for you and you can keep the save!
     
  12. MPilo

    MPilo Member

    Joined:
    May 26, 2017
    Messages:
    66
    Likes Received:
    8

    Ok, I'm able to give you all a report.

    I may have saved my save, the crashes are decreasing... Using some tricks. But I'm able to use fast travel, that's a starting point.

    The plots: Slum Lords were working anyway, it was sufficient to refresh them. Bad Neighbours, all three basic kinds, are working and (like basic residential plots) they had the working ASAM sensor on the pole BEFORE refreshing them, like there was a refresh in all world running in background. Kevbal, in the first two settlements I visited your houses were there and I had to delete the plot and build a new one; the model loaded by the system was the same like it was in memory, but (except in one case) the one from the AIO package was loaded (thanks God, I discovered I had a VIP with one of your houses). After a couple of settlements your houses were just an empty flot without needs, scrapped, rebuilted and everything went ok. Your gardens were already working without any problem, and that is strange since also the better garden ESP was missing listening to the game engine.

    I still have problems fast travelling to Sunshine (that is probably full of Slum Lords) and County Crossing, I have to try the second place now that I have managed to get rid of old plots (got there walking from Bunker Hill, no problem at all). And to increase my suspect of some kind of script refreshing everything in background, my laptop decided for two times to reduce FO4 to icon to give a break to the processor and cool it down.

    In 6 hours I managed to kill just the two raiders between Bunker Hill and County Crossing, I'm never going to repeat a mistake like this (or wait to update all the mods together).
     
    Tinuvia likes this.
  13. kevbal

    kevbal Active Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 9, 2017
    Messages:
    467
    Likes Received:
    178

    glad everything is working out @MPilo , much appreciate your dedication and our sincerest apologies for releasing AIO replacements. It can be a pain to get them updated if you have a large game save.
     
    MPilo and Tinuvia like this.
  14. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    618
    Likes Received:
    632

    Yes, thank you so much, MPilo, for that excellently detailed report! Phew, then I can write that on the webpage. And sorry for all your hassle! Hope you can soon get back to a raider killing spree with nothing stopping you ;)
     
    MPilo likes this.
Thread Status:
Not open for further replies.

Share This Page