the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question Something went wrong with attempting to setup your assault

Dutchygamer

New Member
Messages
4
Recently started a new Fallout 4 playtrough, and decided to give SimSettlements with Conqueror a try. Been playing the Jammer questline, and I'm up to the point that I have Starlight as my main base, and 4 vassals: Tenpines Bluff, Abernathy Farm, Sunshine Tidings and Graygarden.
The issue I run into, is that I can't start any new assaults. If run through the War Planner's desk, after selecting the target and the amount of warriors, it gives the notification that it gathers the soldiers, followed quickly by a message that "Something went wrong with attempting to setup your assault".
If I try to run the same through Jammer, he gets stuck at the same point; the conversation basicly freezes after the "gathering the soldiers" notification. I can move out of the conversation and continue playing, but when facing him it returns to the conversation which doesn't seem to do anything, nor is the assault ever setup properly. In this situation however I don't get the "something went wrong" notification.

Relevant information:
- Mod version is the current version, 4.2.9a.
- Started from standard game start, not using any alternative start mods (as was advised).
- Started with the pre-build cities options, all set to the default values (cities of level 1, no war options).
- In the start-assault conversation with Jammer I get the explanation about how Ranks work. I guess this is linked to the amount of Vassels I currently own.
- My initial plan was to turn Covenant into an Outpost, after I had done it's relevant questline which turned the entire town hostile and is now a town I can build in. Jammer does note that I already own the town when planning an assault on it, but I can continue with it nonetheless.
- After vassalising the last (4th) settlement, I got the first Minutemen raid on my main base.
- I have already recruited Ophilia, and done her wallbuster demonstration.
- In my mod list, SimSettlements related I only have the SimSettlements 3-in-1 pack together with Conqueror. I have no add-on packs or anything else related to SimSettlements. I have a variety of 70-odd other mods, which as far as I can see should not influence SimSettlements.

I have no clue what can be the issue. At first I thought it was because I was attempting to turn an empty town into an Outpost, but after trying various other towns and various other reasons (Vassalising, Outpost), it kept giving the same results.
 

snarkhunter

Member
Messages
90
I have seen this problem as well in my current playthrough. What cured it for me was making sure that I had at least 5 raiders (not settlers or civilians) available and resident in the outpost where I was launching the attack from. Free warriors in other outposts are not available for attacks launched from the outpost where you are, as far as I know. If you use the Gather Around/Specific Role/Warrior option of the Town Gavel tool, and at least 5 NPCs show up to the meeting, you are probably good. You should also see the number 5 (or more) above the warriors icon on the bottom left of your Conqueror HUD (looks like a person carrying a rifle), next to the outpost morale meter. If you are short of free raiders in this outpost, try sending some free ones from other outposts to this one (go to the outpost, find an unassigned raider, use the "R" key when up close, and then Change Outpost.) Or you can wait until new recruits show up (but that could take a while).

Sometimes a raider can appear to be available but hasn't been fully activated in the warrior role. In that case another user reported that setting all free raiders temporarily to another role (like guard), and then back to warrior role, can help clear up the their status, so that they can join an attacking party.

Good luck! Let us know if you get past the issue, or still have problems.
 

Dutchygamer

New Member
Messages
4
As I was struggling with resources in my main base from basicly when I took it over, I tried to keep as many of the raiders at the main base when possible. Vassals have 2/3 raiders in the Guard role, and everyone else was at my main base.
Due to the resource problems I switched almost everyone at the main base to the Worker role when I didn't had any assaults planned (with 2/3 with the Guard role). If I wanted to plan an assault, I gathered everyone around with one of the tools from the City Planner holotape, and switched the necessary amount of raiders to the Warrior role. Mostly I picked 7, and assigned 5 to an assault.

As I've started a new playtrough in the mean time without Conqueror (but with SimSettlements to get the hang of that as a start), I am not sure if the issue you mentioned could be my problem as well. I do recall having the option to pick the amount of warriors, so it had to be at least.

When I have the time I will boot up my Conqueror playthrough again, to see if I can get it to work again with your tips.
 

Dutchygamer

New Member
Messages
4
Okay, so I've got the results in:
Apparently there was a difference between what the HUD said for how many warriors I had at the base, and the actual amount of warriors. The HUD said 5, but when I used the Town Gavel tool to gather round only the warriors, I had 4... Changing one random non-warrior raider to the warrior role changed the amount on the HUD to 6, but now I was able to start an assault if I selected 5 warriors.

Now my question is: is this a common issue? Both the HUD and the assault warrior selection menu told me I had more warriors then I actually had available. Is this solved by reassigning all raiders to a different role?
 

snarkhunter

Member
Messages
90
I've seen the situation you just described several times in Conqueror playthroughs - the HUD meters say there should be enough warriors free to start an assault, but in fact one or more of them actually has some complication preventing their participation. My best guess is that there is some lingering role or work assignment fully or partially in effect on these problem warriors. Unless someone finds and fixes a related bug, then we are likely stuck with this issue for a while. Anyone else with more technical knowledge, please chime in!

The Town Gavel tool seems pretty reliable in summoning warriors that are all ready to go, so I don't think you have to role-reassign anyone that shows up to the meeting. Finding other raider recruits that didn't come to the town meeting and changing their role manually first to guard and then to warrior should give you enough additional warriors to start the next assault.

The only other thing I can suggest is maybe to turn off the Soldier Needs option, which should mean you will get a steady daily stream of new unassigned recruit warriors at all your outposts, even if weapons, food, or money are short in your empire. The tradeoff is that your gameplay will be somewhat simplified and you won't need to constantly re-balance your settlement resource outputs.
 

Dutchygamer

New Member
Messages
4
Well, I've made a note for myself that this issue exists and how to work around it. I actually like the Soldier Needs, else it is way too easy to gather an army.
Playing around with Conqueror did make me realize I need a better PC. I can play Fallout 4 on max settings easily, but some of the pre-build city plans in Conqueror give me quite a bit of lag or other weird slow-loading issues; building parts load in really slow for some reason, and NPC scripts seem to be broken or delayed. I don't blame Conqueror for this, but for now I will skip on it until I have a new rig.

I am not that familiar with the forum rules, but should I mark this thread as [Solved] or not? I have a workaround, but that doesn't solve the issue.
 

snarkhunter

Member
Messages
90
Why not leave it open a bit longer - one of the moderators may see it and either reply with new recommendations, or move it to a bug report.

FYI, you may be able to improve Conqueror performance somewhat on your current PC. Check out my reply in this thread.
 
Top