Bug Settlers unassign themselves

Discussion in 'Salvage Beacons (BUG Reporting Area)' started by Joebenz, Feb 28, 2019.

  1. Joebenz

    Joebenz New Member

    Joined:
    Jan 2, 2019
    Messages:
    3
    Likes Received:
    1

    Whenever i assign a settler to the communications station, after a few seconds, the settler will unassign himself. Been going on for a while on multiple settlements.
     
  2. PaulyG

    PaulyG New Member

    Joined:
    Oct 4, 2018
    Messages:
    8
    Likes Received:
    5

    I'm having the same issue. It was working fine for quite a while, but then suddenly wasn't and this seems to be the issue. At first I thought it was just Nick Valentine but tried with other settlers & same thing.

    I've had a couple of brutal firefights in Sanctuary recently and both times comm ops were killed, but their bodies don't despawn/clear/whatever the lingo is for this. Wondering if that has something to do with it.
     
  3. PaulyG

    PaulyG New Member

    Joined:
    Oct 4, 2018
    Messages:
    8
    Likes Received:
    5

    SB has been buggy/non-functional or otherwise broken for me in all the playthroughs I've used it with now... so I'm giving up on it. Anyone know of any similar mods that help with immersive hoarding? I found one that spawns a caravan with a signal flare...
     
  4. Kytampe

    Kytampe Active Member Staff Member Patreon Supporter Support Team Verified Builder

    Joined:
    Jun 1, 2017
    Messages:
    136
    Likes Received:
    126

    With "unassign" do you mean that they walk away from the com station? They do that from time to time, apparently they are allowed to have coffe breaks and such things. It doesn't mean they actually unassign themselves.
     
  5. PaulyG

    PaulyG New Member

    Joined:
    Oct 4, 2018
    Messages:
    8
    Likes Received:
    5

    Hey, no the chair disappears as well which happens if the station is unattended. I have noticed the settlers wandering off from time to time without the chair disappearing - guessing that's their coffee break - or they've got compassion fatigue from hearing all the horror stories relayed to them by the salvaging teams :P . The bodies of my former comm operators still haven't despawned, but I've assigned Sturges to the comm station since I experienced this bug and it seems to be working again now. I don't think this is a bug anyhow, I think it's that sort of odd glitchy behaviour you get when you've got lots of mods that are frequently attempting to perform functions which the vanilla game never intended. That being said, apart from the performance hit, I find SS really stable.
     

Share This Page