Old Post Remove bed requirement

Discussion in 'Workshop Framework (Mod Suggestions Here)(Archive)' started by notfree25, Jan 11, 2019.

  1. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    Turning the shelter mechanic off doesnt seem to fix bed bugs, its either 4294 or just too few, even when there are beds are player placed(non plots)
    Can bed resource requirement/calculation be removed as a stopgap? It just drains happiness, settlers and mine.

    I spend an hour jumping between settlements, and I only have 7. Its like those whack a mole game. T_T
     
  2. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,452
    Likes Received:
    2,335

  3. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    You mean i should turn shelter mechanics back on and manually run shelter fix instead?

    Does the shelter fix check every settlement? Something i notice was, a few seconds after fast travel, everything will be fine, then a few seconds more, another settlement will get the bed problem.

    Another thing I noticed was, settlements with only player placed beds or (city planned) plot beds(but not both) are stable.

    I check resaver quite often now (given my last fiasco) and the only thing that jumps out is workshop resource manager script
     
    Last edited: Jan 12, 2019
  4. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,452
    Likes Received:
    2,335

    Hummmm, you did get me thinking a bit.

    I am using the Shelter-Fix under "Tools" and running that as a Fix inside each settlement and running it until the beds fix (multiple times) and once fixed it is sticking for the past week. I already understand that in my game the Auto-Shelter-Fix is not working.

    The Shelter-Fix under "Options, Game-Play, Usability" is set to Auto

    MCM Workshop framework is set too "ON"

    I wonder if anyone is confused by this?

    I am using both types of beds in every settlement "plot and vanilla" so Commerical is set right now to population.

    I don't use City Plans.

    There may be something going on with the combination of settings?
    TOOLS menu in halotape -
    Desk.jpg
    MCM
    mcm.jpg
    "Options, Game-Play, Usability" Auto Shelter-Fix" not manual "Still auto is not working right" but I know this.....and don't want to switch it to manual....
    pip.jpg

    Before below
    1.jpg
    After running Shelter-Fix under Tools
    2.jpg
     
  5. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    How did you get that report?
     
  6. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,452
    Likes Received:
    2,335

    It is one of the first choices in the halotape “I think, it is just Reports”

    The screenshots background is why I posted them, there can be some variation of the choices depending on the device
     
  7. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    I dont know if this helps but, after rescuing a settler/ passing by a settlement, the game recalculated my resources again
    1. Tenpines ended up with 2 beds. It has 2 r.plots
    2. Starlight ended up with 1. It has one plot that i seen.
    3. After starlight got recalculated Tenpines ended up with 4294.
    I assume it tried to supply line beds? Whatever.
    I could separate vanilla and plot based villages, but some city plans have low settler limit at low level and even vanilla beds. Besides that breaks the core idea of SS.

    What I dont get is why the game needs to recalculate the values. I am sure it keeps records of already calculated values. Does it not keep surplus information?

    Unless player is adding stuff or it lost a settlement attack, there should not be any changes to the values. Is this vanilla behavior or added by SS to cater for dynamically added plots/upgrades? Can it not just -=/+= newValue?

    Seems overly complicated.
    I have IDEK's surplus uncapped and logistic
     
    Last edited: Jan 12, 2019
  8. Wesley Clark

    Wesley Clark New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    6

    A comment from the vanilla WorkshopParentScript: "when player arrives at a new workshop location, data is refreshed - workshop script only holds full data for a single workshop". So when the data is refreshed the counts are recalculated.

    Now I don't suppose you remember seeing a message along the lines of "A settler at Tenpines Bluff has upgraded his home" prior to 3. in your previous message?

    I'm trying to get some supporting evidence that the 4294 beds occurs when a settlement has a mix of residential plots and standard beds, and an update to a residential plot occurs.
     
  9. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    No I didnt see any messages. There wasnt any upgrades.

    I agree that a mix of plot and vanilla bed can cause this. But not everytime, since my sanctuary havnt been hit so far

    My solution was to use console to control the happiness every few ingame days and forget about it
     
    Last edited: Jan 19, 2019
  10. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    A new settlement got hit again today, Hangman Alley that i took several days building,
    worst part is somehow i cant select the workbench using console prid so i cant adjust the happiness without returning to the settlement.
     
  11. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    If anyone is still checking this,
    I seem to have solved my bed problem by turning off auto assign away from vanilla.

    My guess is script confusion occuring between vanilla/WF and SS assigning
     
  12. Wesley Clark

    Wesley Clark New Member

    Joined:
    Sep 10, 2017
    Messages:
    11
    Likes Received:
    6

    Just tried turning off the "auto assign away from beds" option but that didn't fix the problem for me.
    After resetting the option I went to two of the settlements where the counts have been getting messed up and changed a couple of residential plots so they were level 1, then went on a search for magazines to fill in time and waited a lot till I got messages that the plots had upgraded. After that, one settlement was reporting 4294 beds, the other 12, both settlements have a total of about 40 beds and res. plots each.
     
  13. notfree25

    notfree25 Member

    Joined:
    Dec 26, 2018
    Messages:
    42
    Likes Received:
    11

    Yea, mine didnt stay fixed long.
    New settlers and plot upgrades will easily fudge up the numbers.

    All I wanted was an easier time with building pretty settlements.
    Not more complicated and stressful maintenance
     
    Last edited: Jan 27, 2019

Share This Page