the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Long Save Research Tool

Fabio

New Member
Messages
13
Its not actual data corruption. More of something like a NPC from a mod that didnt spawn correctly. The problem can heppen more on modded installs. Has been an issue with Bethesda games since Morrowind days. I'd try sleeping in an interior cell somewhere like Dugout Inn in Diamond City.
This may be correct, and might be even from vanilla. Once I spawned a raider near Sunshine Tidings just to test turrets, and forgot to reload the save. After a while, I was getting attack warnings in that settlement, and every time I tried to get near it I was crashing. I found out in the Buffout 4 crash logs that the same raider I spawned was causing the crash, because I was able to reload a save from when I killed him and got his ID. It was the same ID the crash log was reporting.

Power grid corruption may cause problem as well, but it takes some time. Avoid using things such as long wires or wireless hacks, and always remove wires before scrapping powered objects. Also do not ever use anything other than the workshop to scrap objects.
 

eMYNOCK

Member
Messages
29
I saw an option there also- power grid tools has a console fix option which I have installed. The problem is, you have to be in a settlement to use both, and I can't get near that settlement without crashing. I even tried changing the speedmult and running in, but to no avail.
i think it has an automatic function (turned off by default) that is called on cell load... could be worth a try.
 

Lowjax

Active Member
Messages
257
Here's something interesting. I've always had save game troubles since I started using mods. They simply wouldn't load, CTD from load screen, buffout blamed Nvidia, reasonable enough, Nvidia and Bethesda games have never gotten along well. However, if I found a game that would load, I could then load the one that originally wouldn't. It got pretty bad, to the point where I had to keep one save I knew would load, so I could then load the newer saves. I assumed there was save corruption and it was getting worse.

Sorry it took so long, but here's the interesting part. I have not had a single problem since installing the Garbage Collection fix. I can even save and exit straight to desktop (skipping the main menu) which I haven't been able to do at all, even vanilla it was maybe 50-50 that a save would load doing that.
 

Mystical Panda

Active Member
Messages
139
Here's something interesting. I've always had save game troubles since I started using mods. They simply wouldn't load, CTD from load screen, buffout blamed Nvidia, reasonable enough, Nvidia and Bethesda games have never gotten along well. However, if I found a game that would load, I could then load the one that originally wouldn't. It got pretty bad, to the point where I had to keep one save I knew would load, so I could then load the newer saves. I assumed there was save corruption and it was getting worse.

Sorry it took so long, but here's the interesting part. I have not had a single problem since installing the Garbage Collection fix. I can even save and exit straight to desktop (skipping the main menu) which I haven't been able to do at all, even vanilla it was maybe 50-50 that a save would load doing that.
The game play to me seems much smoother- probably due to the engine not carrying so much data 'weight' as before, or constantly trying to clear it out. The problem I'm experiencing could be mod related, like a conflict, but I won't know more until I can get tool development completed in my current project. That's going to take some time unfortunately.
 

XxA1xX

Well-Known Member
Community Rockstar
Messages
1,372

Is this actually a thing that needs fixing in SS2? Any correlation with the GC?
It looks like it’s making a few changes to audio files and a couple texture tweaks so unless the author explained better what hes changing I can’t see it doing much.
 

jims1973

New Member
Messages
6
That just means Chapter 2 wasn't installed or wasn't enabled. You don't have to restart.

In the in-game Mods screen, hit the Load Order button and look for SS2_XPAC_Chapter2.esm, make sure it is checked in. If you can't find it there, it means you don't have Chapter 2 installed and might need to redownload it.
I am so effing dumb sometimes. I just got another 15 hours in only to get the “To be continued” I had checked that it was version 51 of SS2 and everything. I just fail to notice Chapter 2 is it’s own add on to SS2. UGH!! Installing it now before I nuke another play through and load order build. How can I be so smart and dumb at the same time?!? Hahaha…
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
4,561
I saw an option there also- power grid tools has a console fix option which I have installed. The problem is, you have to be in a settlement to use both, and I can't get near that settlement without crashing. I even tried changing the speedmult and running in, but to no avail.
Forgot to come back to this thread! In the latest build of Workshop Framework, I added Settlement Recovery Tools to the holotape/MCM. You can use them to attempt and remote repair/reset power grids, or in an emergency reset the entire location record.
 

Doomchild

New Member
Patreon Supporter
Messages
19
Forgot to come back to this thread! In the latest build of Workshop Framework, I added Settlement Recovery Tools to the holotape/MCM. You can use them to attempt and remote repair/reset power grids, or in an emergency reset the entire location record.
found this thread while searching for solutions to my Sanctuary crashing, was unaware of these options. Repair power grid failed & suggested I run Destroy power grid. which I did & it worked, but attempting to repair keeps giving the message that it fails.

on one of the earlier attempts to fix the issue I approached from a different angle and got a popup about Mama Murphy (the mayor) but the game crashed before I could read all of it. I'm not sure if it was related to the crash or some other issue. I had a lot of issues getting Sanctuary to build a city plan before (15 minutes in cinematic camera, nothing changing or being built)

for now, my problem seems fixed. thanks kinggath for making this amazing mod and giving such great support.

edit it worked for a while, but now it's back to crashing when trying to fast travel to sanctuary, I'll try to reset the settlement and see if that fixes it long term :(
 
Last edited:

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
4,561
found this thread while searching for solutions to my Sanctuary crashing, was unaware of these options. Repair power grid failed & suggested I run Destroy power grid. which I did & it worked, but attempting to repair keeps giving the message that it fails.

on one of the earlier attempts to fix the issue I approached from a different angle and got a popup about Mama Murphy (the mayor) but the game crashed before I could read all of it. I'm not sure if it was related to the crash or some other issue. I had a lot of issues getting Sanctuary to build a city plan before (15 minutes in cinematic camera, nothing changing or being built)

for now, my problem seems fixed. thanks kinggath for making this amazing mod and giving such great support.

edit it worked for a while, but now it's back to crashing when trying to fast travel to sanctuary, I'll try to reset the settlement and see if that fixes it long term :(
Did you grab 2.0.0c? Could be you are experiencing the Old Paul outfit bug that we just fixed.

Otherwise, if you're on PC, I'd highly recommend setting up Buffout 4, it will tell you exactly why you are crashing. If it turns out to be a bad model or texture file from SS2 or an addon, we can get that patched immediately!
 

Doomchild

New Member
Patreon Supporter
Messages
19
Did you grab 2.0.0c? Could be you are experiencing the Old Paul outfit bug that we just fixed.

Otherwise, if you're on PC, I'd highly recommend setting up Buffout 4, it will tell you exactly why you are crashing. If it turns out to be a bad model or texture file from SS2 or an addon, we can get that patched immediately!
I did pick up 2.0.2c but it didn't fix the issue, it was likely a compounded problem as multiple bad actors were messing with my game. nvidia drivers crashing, papyrus crashing,...
it could have been one of the crashes early on as I did notice a reference to Old Paul and Raider armor (I think) in the crash logs, but the crash persisted afterwards.
biggest culprit is likely myself as I messed with my load order daily and very likely removed several mods I shouldn't have, trying to save the save with ReSaver 'fixed' nearly 200 orphaned references but didn't end up saving it. it didn't crash going to sanctuary anymore but I was unable to do manual saves, quick saves & auto saves worked but manual saves just booted me to desktop. I gave up and I'm reworking my mod list for a new save. still worried about driver issues as I upgraded from a GTX980 to a GTX1660Ti since my last time playing in 2019. I played for 25-ish hours before the crashes started though, almost as if the initial crash caused the whole house of cards to collapse and every possible issue to pop up.

but I'm getting off topic here XD
initially the workshop framework tools helped me fix a crashing issue, sadly it wasn't the only one.
 
Top