the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Help; blue ghosts and scrapping layout

Josiah77

Member
Messages
56
FAAA9058-53EF-473A-A090-91E7A07394D2.jpegF6D90756-CB64-44B9-9BEF-1F4912958D11.jpeg
Just started RotC SS2 port and I keep having these blue settler idle animation ghosts all over outside of build mode. Also this “Scrapping Layout” status bar that never progresses and never goes away. Is there a way to get rid of both of these things?
 

msalaba

Well-Known Member
Community Rockstar
Messages
2,298
I keep having these blue settler idle animation ghosts all over outside of build mode.
This could be script lag. After placing a city plan, it can take up to 20 min. for the scripts to run.
this “Scrapping Layout” status bar that never progresses and never goes away.
This may be related to the first issue. Sometimes saving, exiting the game and reloading helps. Otherwise there is a "canel stalled status bars" option in the WSFW holotape / MCM settings. If you can, load a save from before you issued the "scrap settlement" command.
 

Josiah77

Member
Messages
56
I’ll try the WSFW fix for the status bar but as far as script lag for the ghosts, it’s been hours since I initiated the city plans. I’m also having these light bulb ghosts. 2DE30749-2FCE-4828-9795-EF02887D30A8.jpeg
 

goodbyeagonyy

New Member
Messages
5
This is happening on my plots as well for tenpines bluff, the slog and bunker Hill - bunker Hill is especially bad as I've got what looks like 3 sets stacked on top of each other and no way to just scrap the city plans (both scrap city plan and refresh city plan aren't doing anything even after waiting 40 minutes per time) I'm now currently stuck in a situation where I'm unable to go to bunker Hill due to the fact my game is dropping from 60+fps to 10fps due to the city duplicating and having these bright blue markers + light bulbs everywhere. Is there a way to fix this or am I just stuck with it?
 

Josiah77

Member
Messages
56
Glad to hear I’m not alone! It has been days for me and it hasn’t gone away. Even after Sanctuary leveled up the blue ghosts are still there. Is it a problem specific to SS2 RotC plans I wonder? What hardware are you playing on? For me it’s on xbox series X.
 

murarst

Active Member
Messages
199
I had the same at starlight drive. I'm on pc. Blue ghosts and lightbulbs. Can't remember how I got there and how it went away. Was quite some time ago and I was mucking about with city plans.
 

goodbyeagonyy

New Member
Messages
5
Glad to hear I’m not alone! It has been days for me and it hasn’t gone away. Even after Sanctuary leveled up the blue ghosts are still there. Is it a problem specific to SS2 RotC plans I wonder? What hardware are you playing on? For me it’s on xbox series X.
I'm on PC
 

WolfQueen

Active Member
Messages
177
This is very strange because I am getting the same problem with the ghosts and the Light bulbs! Another strange thing is I am using MSI pc! O_o
 

Karvoc

Well-Known Member
Patreon Supporter
City Planner (S3)
Verified Builder
Wiki Contributor
Messages
711
Well, the blue people are animation markers, the light bulbs are light source markers and the red floor markers are nav mesh helpers. All are from the WRK. If you can still see this while in-game and not in build mode then something is lagging. Remember Fallout 4 is really ram heavy so be sure to reduce ram usage when experiences issues like this.
 

WolfQueen

Active Member
Messages
177
Well, the blue people are animation markers, the light bulbs are light source markers and the red floor markers are nav mesh helpers. All are from the WRK. If you can still see this while in-game and not in build mode then something is lagging. Remember Fallout 4 is really ram heavy so be sure to reduce ram usage when experiences issues like this.
this makes sense.. I'm going to clean out the mod lists too!
 

Din'elen DarkStar

Well-Known Member
Community Rockstar
City Planner (S3)
Messages
2,286
Well, the blue people are animation markers, the light bulbs are light source markers and the red floor markers are nav mesh helpers. All are from the WRK. If you can still see this while in-game and not in build mode then something is lagging. Remember Fallout 4 is really ram heavy so be sure to reduce ram usage when experiences issues like this.
The WRK is a great mod but only useful if you are doing a lot of hand-built settlements and want more vanilla assets to build with and less mods to do it with.
 

xinuxunil

New Member
Messages
1
I have the same issue with Tenpine Bluffs. It seems to me that players shouldn't see these models during regular gameplay, so I'm wondering if the city plan author forgot to set or unset something before deploying. This issue only seems to manifest with the RotC SS2 city plan, and so far only in TPB.
 

Din'elen DarkStar

Well-Known Member
Community Rockstar
City Planner (S3)
Messages
2,286
No they should disappear when leaving workshop mode. If not it's serious script lag. There is no setting for authors to change these idle markers. Which is what you are seeing.
 

Ernesto

Active Member
Messages
287
The options for it to be seen are here. These options are enabled by default, so when you build something you can see animation markers, lights, etc.
Once built, even if the options are disabled, all these objects will remain. They must be deactivated before building.
ScreenShot681.png
No they should disappear when leaving workshop mode. If not it's serious script lag.
I guess I have serious lag problems because they appear and disappear continuously, in and out of the workshop mode. Fortunately, since I already knew about the problem, I disabled the options in my new game before building anything.
 

Karvoc

Well-Known Member
Patreon Supporter
City Planner (S3)
Verified Builder
Wiki Contributor
Messages
711
being able to see them in build mode is a huge boon if you are going to add to a city plan and I as a city builder have this option on all the time as I need to be able to see them when building. being able to see this outside of the build mode is just the game being a Bethesda game, nothing to really worry about.
 
Top